vSphere 5.5 & 6.0 how to add domain users to SSO

So you’ve installed your ESX servers and installed vCenter along with its SSO, Inventory Services and Web Client, you’ve even installed the Windows vSphere UI just because that’s what you’re used to and now when you’re connecting to your new environment your getting a “You do not have permission to login to this server”
VC Login Issues
So with this new version of vSphere you need to enable access for your domain users/groups so that they have access to vCenter.
To get you up and running fast follow these simple steps. for best practices configuring SSO please reference the VMware documentation.
1. Login to the Web client “https://client-hostname:9443/vsphere-client” with [email protected] using the password of what ever you configured SSO password as. *Note you can only configure SSO using the Web Client*
2. Navigate to vCenter Servers > Manage > Permissions, click on the + to add a user
3. Now add your Domain user or group that you would like to have access to vCenter along with the permissions required and click on OK.
4. Try and login with the user you just configured and you should now have access to the Web client or the Windows vSphere UI.
Adding Domain User to SSO
 
vSphere-land.com is out their to ask your opinion about the Top Virtualization Blogs which have helped you in the Past Year to Learn, Explore & Master the Virtualization Technology & the related Eco-system.
If my Blog has helped you in your journey of Virtualization, I would of course be grateful if you did spend a VOTE for me on their survey.
You can VOTE by clicking on the following link.

Please follow and like us:

38 Replies to “vSphere 5.5 & 6.0 how to add domain users to SSO”

  1. Okay, I am struggling. I got logged in to do what you said above, but I do not have a Manage option under vCenter Servers. Am I missing something.

  2. That does not appear to work correctly. I am beginning to think there may be an installation issue. Is there a problem with just going ahead and reinstalling vSphere 5.5 vCenter server installation?

  3. Perfect! Thanks for posting this. The VMware documentation and KBs had me going in the wrong direction. This post is spot on! Thanks.

  4. I redid everything to no avail. This server was installed from scratch due to a lost server, so I have no Inventory. Could that be why I do not have the Manage option?

  5. One thing that doesn’t work at least for me is adding a domain user to the “Administrators” group under SSO. I have to add the domain user explicitly to the vCenter server permissions. Domain lookups routinely fail as well. 5.5 seems a little buggy

  6. Really clear, good information and got me logging in with my network creds, after one thing, maybe I missed it when adding my account but when I added my account at first I didn’t see the default setting of No Access, but after modifying that, was good to go. Great information, will be back.

  7. Great Post.. Could you help me integrate vCenter Server appliance with AD. I’m already using an AD for authentication. Is there anything else I have to do so that users from the domain can be given permission to access vcenter ?

  8. Thanks for the instructions, I am able to login to my vcenter web client using my domain account. The problem I am having is that I am missing the permissions and resources that my [email protected] is able to see and get access to. I’ve been searching VMWARE’s KB but their explanation is very vague.

Leave a Reply

Your email address will not be published. Required fields are marked *